web interface system requirements


This article is designed to provide you with guidelines for the minimum and recommended system requirements for running both the Server and Client components of the finPOWER Connect Web Interface.


The finPOWER Connect Web Interface may be customised, therefore any custom scripts, pages etc may affect minimum requirements.


These recommendations are guidelines only, requirements may vary with each installation and intended use of the system.



Minimum Server Requirements

finPOWER

The following are the minimum requirements for Server components of the Web Interface.

  • Windows Server 2003 or above running Internet Information Services (IIS).
  • ASP.NET installed.
  • .NET framework version 3.5 or above installed.
  • A SSL certificate installed under IIS.
  • finPOWER Connect database connection on the local network.
  • If Document Manager functionality is required a connection to the Document Manager path.

It is highly recommended that the finPOWER Connect SQL Server Add-On is used with the finPOWER Connect Web Interface.



Minimum Client Requirements

The following browsers have been tested and are currently supported.

  • Internet Explorer 8, may have some minor issues.
  • Internet Explorer 9 or later.
  • Google Chrome.
  • Firefox 4.3 or later.
  • Safari 5.0.5 or later.

The finPOWER Connect Web Interface should work fine on most mobile and touch devices, however such devices are not the primary target of the finPOWER Connect Web Interface. Note, logging in with "Mobile" mode switched on assists with small screen devices.


JavaScript and Cookies must be enabled in the browser.